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INTRODUCTION TO ARDUINO

Arduino is a small single-board computer based on microcontrollers. Arduino was first
introduced in 2005. It is an open-source platform. Unlike the Raspberry Pi, the Arduino is not
intended to be a full-fledged desktop computer. It is most often used to implement standalone

interactive electronic circuits.

EXAMPLES OF MODELS

ARDUINO NANO

Arduino Nano is one of the smallest development boards. The development board includes an
Atmel ATmega328 microcontroller as standard and 32KB flash memory. It has 14 input/output

pins.

ARDUINO UNO

Arduino Uno is one of the most famous development boards. The development board includes
an Atmel ATmega328P microcontroller as standard and 32KB flash memory. It has 14
input/output pins.

ARDUINO MEGA

Arduino Mega includes a more powerful Atmel ATmega2560 processor. It has 256 kB of
memory and 54 input/output pins.

There are others — Arduino Due, Arduino Leonardo, Arduino Micro...

More information can be found at hitps://store.arduino.cc/collections/boards.

Quick overview

Model Microcontroller Flash ~ EEPROM SRAM Digital [/O PWM Analog

KiB KiB KiB pins channels inpufs

Diecimila | ATmega168 16 0.5 1 14 6 6
Duemilanove | ATmegal68/328P 16/32 0.5/1 1/2 14 6 6
Uno | ATmega328P 32 1 2 14 6 6

Due | ATMEL SAM3U 256 50 16

Mega | ATmegal1280 128 4 8 54 14 16

Mega2560 | ATmega2560 256 4 8 54 14 16

Leonardo | ATmega32u4 32 1 2 14 6 12
Fio | ATmega328P 32 1 2 14 6 8



https://store.arduino.cc/collections/boards

Nano | ATmega168 or 16/32 0.5/1 1/2

ATmega328
LilyPad | ATmegal68V or 16 0.5 1
ATmega328V
Yin | Atheros AR9331 — 16 MiB 1 64
400MHz (32KiB) MiB
(ATmega32u4) SPRZ
(1KiB)

14 6 8
14 6 6
20 7 12
(ATmega32u4)

STARTING WITH ARDUINO

For the first steps with Arduino, we need:

software — Arduino IDE,
Arduino development board,
USB cable,

computer or laptop,

SN NN

electronic components or sensors and wires.

DEVELOPMENT ENVIRONMENT

The program can be downloaded from websites for various types of operating systems.

https: //www.arduino.cc/en/software

Downloads

Arduino IDE 1.8.16

The open-source Arduino Software (IDE) makes it easy to write code
and upload it to the board. This software can be used with any
Arduino board.

Refer to the Getting Started page for Installation instructions.

SOURCE CODE

Active development of the Arduino software is hosted by GitHub.
See the instructions for building the code. Latest release source
code archives are available here. The archives are PGP-signhed so
they can be verified using this gpg key.

DOWNLOAD OPTIONS

Windows Win 7 and newer
Windows zIF file

Windows app Win 8.1 0r 10 Get £8

Linux 32 bits
Linux 64 bits
Linux ARM 32 bits
Linux ARM 64 bits

Mac OS X 10.10 or newer

Release Notes Checksums (sha512)

Source of the screenshot: hitps://www.arduino.cc/en/software


https://www.arduino.cc/en/software

INSTALLATION PROCEDURE

There are two ways to install Arduino IDE for Windows. Either the installation file runs or unpacks

the ZIP archive.

We are going to use the first option — run the downloaded setup file.

@I Arduine Setup: License Agreement — *

Il Please review the license agreement before installing Arduino. If you
2.2 accept all terms of the agreement, didk I Agree.

SNU LESSER. GEMERAL PUBLIC LICEMSE '
Version 3, 29 June 2007
Copyright (C) 2007 Free Software Foundation, Inc. <htto://fsf.org/=

Everyone is permitted to copy and distribute verbatim copies of this license
document, but changing it is not allowed,

This version of the GMU Lesser General Public License incorporates the terms
and conditions of version 3 of the GNU General Public License, supplemented
by the additional permissions listed below.

Cancel I Agree

It is required to accept all terms of the License Agreement. Press the | agree button.

In the next window, leave all options checked and press the Next button.

@ Arduing Setup: Installation Options — >

B, Check the components you want to install and uncheck the components
2.2 you don't want to install. Click Mext to continue,

Install Arduino software
Install USE driver
Create Start Menu shortcut
Create Desktop shortout
Associate .ino files

Select components to install:

Space required: 543.9MB

Cancel < Back | Mext = |

Select the folder where the program will be installed.



@l Arduine Setup: Installation Folder

installation.

— X

Setup will install Arduino in the following folder, To install in a different
o folder, dick Browse and select another folder. Click Install to start the

I D:pArduino

"Desﬁnaﬁun Folder

Browse. .. |

Space required: 543.4MB
Space available: 595, 2GE

Cancel | Mullsoft Install Swstem »3.0

< Back | Install I

@ Arduino Setup: Installing —

Extract: arduino-builder exe... 97%

|

@ Arduine Setup: Installing

Extract: jfert.jar
oo e —

i Show details |

Cancel | Mullsoft Install System 3.0 < Back. | Close

Cancel | Mullsoft Install System v3.0 < Back | Close

If drivers will be installed — we will enable the installation.

E=] Zabezpeceni Windows

= \fydavatel: Adafruit Industries

Industries

Widy diwvéfovat softwaru od spoleénosti Adafruit

Checete nainstalovat tento software zafizeni?

Mazew: Adafruit Industries LLC Porty (COM a LPT...

Instalovat

E Meinstalovat i

(¥ Doporuéujeme instalovat pouze software zafizeni od didvéryhodnych vydavateld. Jak rozhodnout, ktery
software zafizeni je moiné bezpeéné nainstalovat?




E=] Zabezpeceni Windows *

Checete nainstalovat tento software zafizeni?

Mazew: Arduino USB Driver
= \/ydavatel: Arduino srl

Vidy divéfovat softwaru od spoleénosti Arduino srl Instalovat E MNeinstalovat i

(¥ Doporucujeme instalovat pouze software zafizeni od ddvéryhodnych vydavateld. Jak
rozhodnout, ktery software zafizeni je moiné bezpeéné nainstalovat?

After installation, the message Completed appears.

@ Arduing Setup: Completed —

Completed
Show details |

Zancel | Mullsoft Install Swstem »3.0 < Back |

The Arduino icon appears on the Windows desktop.

0.0

Arduino

Note: Installation on another operating system is eg. on https://www.arduino.cc/en/guide/linux

or https://ubuntu.com/tutorials/install-the-arduino-ide#1-overview

CONNECTING THE DEVELOPMENT BOARD

Connect the Arduino board to your computer using a USB cable. Development boards are

usually powered from USB or from an external supply. When connected, the green LED should

light up.



INSTALLING THE ARDUINO MEGA 2560 DRIVER

In Windows 10, driver installation should run automatically. Alternatively, you can check in the

Device Manager menu — COM Ports entry.

LAUNCH THE ARDUINO IDE

In the Tools > Board menu, select the board type.

File Edit Sketch Tools Help

Auto Format Ctrl+T
Archive Sketch
sketch_oct22a Fix Encoding & Reload
vold setup () Manage Libraries... Ctrl+ Shift+|
[/ BEE VOEE serial Monitor Ctrl= Shift+ M
1 Serial Plotter Ctrl+5Shift+L
void loop() [ WiRT01 /S WikiNINA Firmware Updater

S/ put your

Board: "Arduing Unc" b Boards Manager...
} Port ] Arduine Yin
Get Board Info ®  Arduinoc Uno

Arduino Duemilanove or Diecimila

Programrmner: "AVRISP mikll"

Burn Bootloader Arduino Mano

Arduino Mega or Mega 2360
Arduine Mega ADK
Arduino Lecnardo

Arduino Leonardo ETH

Arduine Micro
Arduino Esplora
Arduine Mini

Arduino Ethernet
Arduino Fio

Arduine BT

LilyPad Arduine USE
LilyPad Arduino
Arduine Pro or Pro Mini
Arduine MG or older
Arduino Robot Control
Arduine Robot Motor
Arduine Gemma
Adafruit Circuit Playground
Arduine Ydan Mini
Arduine Industrial 101
Linino One

Arduino Uno WiFi




In some cases, we also have to select a processor.

File Edit Sketch Tools Help

sketch_oct22a

violid setup()
S/ put your

viold loop() |
Sf put your

Autc Format

Archive Sketch

Fix Enceding & Reload
Manage Libraries...
Serial Monitor

Serial Plotter

WIFI01 7 WiFiNIMA Firmware Updater

Board: "Arduino Mega or Mega 2560"
Processon "ATmega2 560 (Mega 2560)"

Port
Get Board Info

Prograrmmer: "AYRISP mkll"

Burn Bootloader

The next step is to select a port in Tools > Port.

File Edit Sketch Tools Help

sketch_octZ2a

void setup()
f/ put your

}

vold loop() {
ff put your

Auto Format

Archive Sketch

Fix Encoding & Reload
Manage Libraries...
Serial Monitor

Serial Plotter
WIF101 S WiFININA Firmware Updater

Board: "Arduino Mega or Mega 2560"
Processor: "ATmega2360 (Mega 2560)"
Port

Get Board Info

Programmer: "AVRISP mkll"

Burn Bootloader

Ctrl+T
Ctrl+Shift+]
Ctrl+Shift+M
Ctrl+Shift+L
»
i @ ATmegal360 (Mega 2560)
: ATmegal2l0
>
Ctrl+T
Ctrl+Shift+|
Ctrl+Shift+M
Ctrl+Shift+L
;]
;]
; Serial ports
COM3 (Arduino Mega or Mega 2560)
>

TESTING THE CONNECTION

We will create a short program for testing. The goal will be to blink the BUILTIN LED on the

development board.

We will run the program.




i +lolvi-§
Genuino
ARDUINO

AM OPEM PROJECT WRITTEN, DEBEUGGED,
AMD SUPPORTED BY ARDUINO.CC AND
THE ARDUING COMMUMITY WORLDWIDE

LEARM MORE ABOUT THE COMTRIBUTORS

of EEIIELTHEIN on arduino.cofcredits

=[2 0= =3 K=

File > Save — filename: led

@ led | Arduino 1.8.15
File Edit Sketch Tools Help

led

void setup() {
pinMode (LED BUILTIN, OUIPUT);

vold loop () {
digitalWrite (LED BUILTIN, HIGH):
delay (250):
digitalWrite (LED BUILTIN, LOW):
delay (250):

We will upload the program to the development board.

File Edit Sketch Tools Help

After a successful upload, the program will automatically start. The LED starts blinking.



THE SECOND PROGRAM — EXTERNAL LED BLINK

Required components: Arduino development board, LED, ballast resistor 100 Q, jumper wires.

We will make the wiring according to the diagram below.
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Initialize the digital PIN 2 as the output.

setup(){

pinMode(2, OUTPUT);

L ME GA R85

4y

We will want the LED to blink. That means it will be on for 1 second and then off for 1 second.

loop() {
digitalWrite(2, HIGH);
delay(1000);
digitalWrite(2, LOW);

delay(1000);




This code writes a logical 1 (HIGH) to the PIN 2. It leaves it there for 1 second
(1000 milliseconds). Then it writes a logical O (LOW) to the same pin, which is left there again

for 1 second. It is repeated in the infinite loop.

The digitalWrite function has two parameters. The first is the pin to be controlled and the second

is the logical value.
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TRAFFIC LIGHTS

We will try to simulate traffic lights. The states of the lights are shown on the image below.
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Wiring schema:
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LED_RED = 3;
LED_YELLOW = 4;
LED_GREEN = 2;

setup()

pinMode (LED_RED, OUTPUT);
pinMode (LED_YELLOW, OUTPUT);
pinMode (LED_GREEN, OUTPUT);

Loop()

digitalWrite(LED_RED, HIGH);
digitalWrite(LED_YELLOW, LOW);
digitalWrite(LED_GREEN, LOW);
delay(2000);

digitalWrite(LED_YELLOW, HIGH);
delay(1000);

digitalWrite(LED_RED, LOW);

digitalWrite(LED_YELLOW, LOW);
digitalWrite(LED_GREEN, HIGH);
delay(4000);

digitalWrite(LED_YELLOW, HIGH);
digitalWrite(LED_GREEN, LOW);
delay(1000);




READING ANALOG VALUE OF PIN

const int PIN_FLEX SENSOR = 10;

int flexSensorState = 9;

void setup() {

Serial.begin(96090);

void loop()

{

flexSensorState = analogRead(PIN_FLEX SENSOR);

Serial.println(flexSensorState);

delay(50);




In this example is demonstrated reading values from analog pins. It uses the analogRead method
that reads value from the specified analog pin. Arduino boards contain a multichannel, 10-bit
analog to digital converter. This means that it will map input voltages between 0 and the

operating voltage (for example 5 V) into integer values between 0 and 1023.
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MORE EXAMPLES

Arduino IDE has built-in examples for the basic situations.

&) Blink | Arduino 1.8.16
File Edit Sketch Tools Help

Page Setup  Ctrl+5Shift+P
Print Ctrl+P

Preferences  Ctrl+ Comma

MNew Ctrl+M

Open... Ctrl+0

Open Recent -
Sketchbook >
Examples :
Cloze Ctrl+W

Save Ctrl+5

Save As... Ctrl+5hift+5

[/ the setup functicn runs
wvoid setup() |
S/ initialize digital pi
pinMode (LED_BUILTIN, OUT
1

[/ the loop functicn runs

void loop() {
digitalWrite (LED BUILTIHN
delay {1000} ;
digitalWrite (LED BUILTIN
delay {1000} ;

Built-in Examples
01.Basics

02.Digital
03.Analog

. Cormmunication
05.Control
0B.5ensors
07.Display
08.5trings

09.USB
10.5tarterkit_Basickit
11.Arduinol5P

Examples for any board
Adafruit Circuit Playground
Bridge

Esplora

Ethernet

Firmata

G5SM

LiquidCrystal

Robot Control

Robot Motor

sD

Servo

Spacebrew’un

Stepper

Temboo

RETIRED

Examples for Arduine Mega or Mega 2560

EEPROM
SoftwareSerial
SPI

Wire

AnalogReadSerial
BareMinimum
Blink
DigitalReadSerial
Fade
ReadAnalogVoltage

board

the woltage lewvel)

g the woltage LOW




ONLINE SIMULATION

There are many online simulators that can be used to learn programming of Arduino without the

physical board.

One of the best simulators is Tinkercad Circuits from Autodesk company.

https://www.tinkercad.com/
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